[Mongrel] logger & debug level

John Weir john at smokinggun.com
Wed Dec 12 12:47:59 EST 2007


greetings,

i am getting the below error message in my mongrel log and I want to  
turn that 22 levels into a full trace.  but i am unsure where or how  
to configure the debug level for mongrel.  any advice?

thanks - john

/usr/lib/ruby/gems/1.8/gems/ruby-debug-0.9.3/cli/ruby-debug/ 
interface.rb:24:in `join': can't convert nil into String (TypeError)

         from /usr/lib/ruby/gems/1.8/gems/ruby-debug-0.9.3/cli/ruby- 
debug/interface.rb:24
         from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb: 
27:in `gem_original_require'
         from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb: 
27:in `require'
         from /var/www/foo/live/vendor/rails/activerecord/lib/../../ 
activesupport/lib/active_support/dependencies.rb:496:in `require'
         from /var/www/foo/live/vendor/rails/activerecord/lib/../../ 
activesupport/lib/active_support/dependencies.rb:342:in  
`new_constants_in'
         from /var/www/foo/live/vendor/rails/activerecord/lib/../../ 
activesupport/lib/active_support/dependencies.rb:496:in `require'
         from /usr/lib/ruby/gems/1.8/gems/ruby-debug-0.9.3/cli/ruby- 
debug/processor.rb:1
         from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb: 
27:in `gem_original_require'
          ... 22 levels...
         from /usr/lib/ruby/gems/1.8/gems/mongrel-1.0.1/lib/mongrel/ 
command.rb:211:in `run'
         from /usr/lib/ruby/gems/1.8/gems/mongrel-1.0.1/bin/ 
mongrel_rails:243
         from /usr/bin/mongrel_rails:16:in `load'
         from /usr/bin/mongrel_rails:16


More information about the Mongrel-users mailing list