[Mongrel] mongrel startup fails now: already initialized constant

Luis Lavena luislavena at gmail.com
Wed Dec 5 13:55:44 EST 2007


On Dec 5, 2007 3:31 PM, Roger Pack <lists at ruby-forum.com> wrote:
> In my case this didn't help--when I tried to boot script/server webrick
> it booted webrick THEN mongrel (odd).   Temporary fix: gem uninstall
> mongrel
> > I had a similar problem today that was resolved by uninstalling and
> > re-installing mongrel. I don't have ruport installed. I tried
> > uninstalling gem_plugin first and then reinstalling, but that seemed to
> > make no difference, mongrel still died with the "options" method error
> > for Array.  In case it helps, here are the relevant lines:
> >

script/server is borked.

Historically it do odd things with the way it loads and loads mongrel,
if you search this list you will find a few cases that describe this
situation.

I suggest stick to mongrel_rails start or mongrel_service in case
you're running on Windows.

-- 
Luis Lavena
Multimedia systems
-
Leaders are made, they are not born. They are made by hard effort,
which is the price which all of us must pay to achieve any goal that
is worthwhile.
Vince Lombardi


More information about the Mongrel-users mailing list