[Mongrel] Mongrel 1.1.1 Win32 (latest) + Rubygems

Luis Lavena luislavena at gmail.com
Tue Dec 4 15:15:50 EST 2007

On Dec 4, 2007 5:05 PM, A R <ftotheu at gmail.com> wrote:
> Hello all. Hope this doesn't appear as spam...
> I am trying to run Mongrel on Win XP (SP2) for a web site (just one at the
> moment). For some reason it is giving me this error:


This is a known problem with RubyGems 0.9.5

You should downgrade back to 0.9.4 until or greater get
released (since I think is fixed on trunk).

Oh, also remove the -d (daemonize) option from the command line,
daemonize requires fork() which don't work under Windows.

For running mongrel_rails in a deattached (background) fashion, please
take a look at mongrel_service gem.


Luis Lavena
Multimedia systems
Leaders are made, they are not born. They are made by hard effort,
which is the price which all of us must pay to achieve any goal that
is worthwhile.
Vince Lombardi

More information about the Mongrel-users mailing list