[Mongrel] ERROR: Failed to build gem native extension.

Luis Lavena luislavena at gmail.com
Sun Apr 29 23:05:14 EDT 2007


On 4/29/07, Isaac <zack99 at gmail.com> wrote:
> Hi all,
> I'd really appreciate some help with this...
>
> As you see below, I tried to install mongrel after updating my gems, but I
> get the error shown:
>
> sudo gem install mongrel
> Select which gem to install for your platform (i486-linux)
>  1. mongrel 1.0.1 (ruby)
>  2. mongrel 1.0.1 (mswin32)
>  3. mongrel 1.0 (mswin32)
>  4. mongrel 1.0 (ruby)
>  5. Skip this gem
>  6. Cancel installation
> > 1
> Install required dependency fastthread? [Yn]
> Select which gem to install for your platform (i486-linux)
>  1. fastthread 1.0 (ruby)
>  2. fastthread 1.0 (mswin32)
>  3. fastthread 0.6.4.1 (mswin32)
>  4. fastthread 0.6.4.1 (ruby)
>  5. Skip this gem
>  6. Cancel installation
> > 1
> Building native extensions.  This could take a while...
> ERROR:  While executing gem ...
> (Gem::Installer::ExtensionBuildError)
>     ERROR: Failed to build gem native extension.
>
> ruby extconf.rb install mongrel
> extconf.rb:1:in `require': no such file to load -- mkmf (LoadError)
>         from extconf.rb:1
>
>

It looks like you have a broken ruby installation.

Debian? try doing:

ruby -w -rubygems -e 'require "mkmf"'

and post the log here.

But I could bet you're missing build environment :-)

>
> Please help!
> Regards,
> Isaac
>

Regards,

-- 
Luis Lavena
Multimedia systems
-
Leaders are made, they are not born. They are made by hard effort,
which is the price which all of us must pay to achieve any goal that
is worthwhile.
Vince Lombardi


More information about the Mongrel-users mailing list