[Mongrel] ERROR: Failed to build gem native extension.

Isaac zack99 at gmail.com
Sun Apr 29 22:59:57 EDT 2007


Hi all,
I'd really appreciate some help with this...

As you see below, I tried to install mongrel after updating my gems, but I
get the error shown:

sudo gem install mongrel
Select which gem to install for your platform (i486-linux)
 1. mongrel 1.0.1 (ruby)
 2. mongrel 1.0.1 (mswin32)
 3. mongrel 1.0 (mswin32)
 4. mongrel 1.0 (ruby)
 5. Skip this gem
 6. Cancel installation
> 1
Install required dependency fastthread? [Yn]
Select which gem to install for your platform (i486-linux)
 1. fastthread 1.0 (ruby)
 2. fastthread 1.0 (mswin32)
 3. fastthread 0.6.4.1 (mswin32)
 4. fastthread 0.6.4.1 (ruby)
 5. Skip this gem
 6. Cancel installation
> 1
Building native extensions.  This could take a while...
ERROR:  While executing gem ... (Gem::Installer::ExtensionBuildError)
    ERROR: Failed to build gem native extension.

ruby extconf.rb install mongrel
extconf.rb:1:in `require': no such file to load -- mkmf (LoadError)
        from extconf.rb:1


Gem files will remain installed in /usr/lib/ruby/gems/1.8/gems/fastthread-
1.0 for inspection.
Results logged to /usr/lib/ruby/gems/1.8/gems/fastthread-1.0
/ext/fastthread/gem_make.out

Please help!
Regards,
Isaac
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/mongrel-users/attachments/20070430/b5ca5af3/attachment.html 


More information about the Mongrel-users mailing list