[Mongrel] NoMethodError exceptions

Ezra Zygmuntowicz ezmobius at gmail.com
Sun Apr 29 12:37:29 EDT 2007


On Apr 29, 2007, at 6:44 AM, James Mead wrote:

> On 29/04/07, Will Green <will at hotgazpacho.com> wrote:
> Upgrade your Mongrel to the latest (1.0.1), and try again.
>
> Using gem install or gem update - I always get 0.3.3 version of  
> mongrel. Presumably a mirror issue...?
>
> However, I downloaded the 1.0.1 gem and tried to install it, but it  
> looks like mongrel needs ruby 1.8.4 or greater and I only have  
> 1.8.2 on this machine.
>
> $ sudo gem install /Users/jamesmead/downloads/mongrel- 1.0.1.gem -- 
> include-dependencies
> Password:
> ERROR:  While executing gem ... (RuntimeError)
>     Error instaling /Users/jamesmead/downloads/mongrel-1.0.1.gem:
>         mongrel requires Ruby version >= 1.8.4
>
> $ ruby --version
> ruby 1.8.2 (2004-12-25) [powerpc-darwin8.2.0]
>
> So I assume my only option is to upgrade my ruby version...?
> -- 
> James.
> http://blog.floehopper.org


James-

	Mongrel has *always* required ruby 1.8.4 or later. So you will have  
to upgrade ruby if you plan on using mongrel peridion.

Thanks

-- Ezra Zygmuntowicz 
-- Lead Rails Evangelist
-- ez at engineyard.com
-- Engine Yard, Serious Rails Hosting
-- (866) 518-YARD (9273)




More information about the Mongrel-users mailing list