[Mongrel] NoMethodError exceptions

James Mead jamesmead44 at gmail.com
Sun Apr 29 09:44:08 EDT 2007


On 29/04/07, Will Green <will at hotgazpacho.com> wrote:
>
> Upgrade your Mongrel to the latest (1.0.1), and try again.
>

Using gem install or gem update - I always get 0.3.3 version of mongrel.
Presumably a mirror issue...?

However, I downloaded the 1.0.1 gem and tried to install it, but it looks
like mongrel needs ruby 1.8.4 or greater and I only have 1.8.2 on this
machine.

$ sudo gem install
/Users/jamesmead/downloads/mongrel-1.0.1.gem--include-dependencies
Password:
ERROR:  While executing gem ... (RuntimeError)
    Error instaling /Users/jamesmead/downloads/mongrel-1.0.1.gem:
        mongrel requires Ruby version >= 1.8.4

$ ruby --version
ruby 1.8.2 (2004-12-25) [powerpc-darwin8.2.0]

So I assume my only option is to upgrade my ruby version...?
-- 
James.
http://blog.floehopper.org
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/mongrel-users/attachments/20070429/d516ab4f/attachment.html 


More information about the Mongrel-users mailing list