[Mongrel] mongrel on linux error - custom_require.rb:27:in `gem_original_require': no such file to load -- (LoadErro

Wayne E. Seguin wayneeseguin at gmail.com
Fri Apr 13 08:48:53 EDT 2007


You're missing a gem.
Did you install fastthread?

   ~Wayne

On Apr 13, 2007, at 08:42 , Asif Ali wrote:
> We're deploying mongrel with Apache on CentOS.
>
> I have installed mongrel but when I try to run it, I get the  
> following error.
>
> Can someone tell my why and how to fix it. Also does anyone have  
> experience in deploying mongrel on CentOS ?
>
> mongrel_rails start -d
> /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in  
> `gem_original_require': no such file to load -- (LoadError)
>         from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb: 
> 27:in `require'
>         from /usr/lib/ruby/gems/1.8/gems/mongrel_service-0.1/lib/ 
> mongrel_service/init.rb:5
>         from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb: 
> 27:in `gem_original_require'
>         from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb: 
> 27:in `require'
>         from /usr/lib/ruby/gems/1.8/gems/gem_plugin-0.2.2/lib/ 
> gem_plugin.rb:134:in `load'
>         from /usr/lib/ruby/site_ruby/1.8/rubygems/source_index.rb: 
> 142:in `each'
>         from /usr/lib/ruby/site_ruby/1.8/rubygems/source_index.rb: 
> 142:in `each'
>         from /usr/lib/ruby/gems/1.8/gems/gem_plugin-0.2.2/lib/ 
> gem_plugin.rb:112:in `load'
>         from /usr/lib/ruby/gems/1.8/gems/mongrel-1.0.1/bin/ 
> mongrel_rails:240
>         from /usr/bin/mongrel_rails:18:in `load'
>         from /usr/bin/mongrel_rails:18
>
>
> Thanks in Advance.
>
> Dude
> _______________________________________________
> Mongrel-users mailing list
> Mongrel-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/mongrel-users



More information about the Mongrel-users mailing list