[Mongrel] Mongrel dying daily with Ruby 1.8.6

Pete DeLaurentis pete at nextengine.com
Wed Apr 4 10:27:27 EDT 2007


Hi Eden,

I'm running mongrel1.0.1, mongrel cluster 0.2.1, rails 1.2.3, and  
fastthread 1.0.

I just cleaned up all old gems (since I had some back versions) and  
re-updated all of these gems just to be sure.  Tomorrow morning, I'll  
get to see if this helped :-)

-Pete

On Apr 4, 2007, at 7:11 AM, Eden Li wrote:

> Which version of rails are you using?  Version prior to 1.2.3 have a
> few issues...  Also, what version of mongrel are you running?
>
> On 4/4/07, Pete DeLaurentis <pete at nextengine.com> wrote:
>> Hi Eden,
>>
>> I agree: a common issues page is a great idea.  Unfortunately, this
>> issue doesn't seem to be one of the usual suspects.
>>
>> 1. The logs just have normal chatter for my app ... nothing unusual
>> 2. No rmagick or ferret, but I believe it is related to Ruby 1.8.6,
>> since that's when ti started dying.
>> 3. I'm not using log rotation, but the files aren't that big after a
>> day.. and there's plenty of free space on disk
>>
>> Here's a question: Is anyone running ruby1.8.6 succesfully with  
>> mongrel?
>>
>> Thanks,
>> Pete
>>
>>
>>
>> On Apr 4, 2007, at 6:01 AM, Eden Li wrote:
>>
>>> Standard questions come to mind:
>>>  - What do your logs say?
>>>  - Are you running anything semi-dangerous like rmagick or older
>>> versions of acts_as_ferret?
>>>  - Are you using Ruby based log rotation?
>>>
>>> BTW, maybe we could put up solutions to common issues into a page on
>>> mongrel.rubyforge.org? I don't see one on
>>> http://mongrel.rubyforge.org/docs/index.html...
>>>
>>> On 4/4/07, Pete DeLaurentis <pete at nextengine.com> wrote:
>>>> Hi guys,
>>>>
>>>> I've been running mongrel for a while now with Ruby 1.8.4, and last
>>>> week upgraded to 1.8.6.
>>>>
>>>> Since upgrading, each morning when I wake up there's a big problem:
>>>>
>>>> 1. Accessing the site returns a "500 Internal Server Error"
>>>> 2. All the mongrel_rails processes are still running, but none of
>>>> them are active (when I run top)
>>>> 3. Lighttpd and pound are still running nicely
>>>> 4. There's plenty of free RAM
>>>> 5. There's plenty of free HD
>>>> 6. When I restart mongrel, it all starts working again
>>>>
>>>> I haven't seen anything like this before.  Does this sound familiar
>>>> to anyone?
>>>>
>>>> Thanks for the help,
>>>> Pete
>>>> _______________________________________________
>>>> Mongrel-users mailing list
>>>> Mongrel-users at rubyforge.org
>>>> http://rubyforge.org/mailman/listinfo/mongrel-users
>>>>
>>> _______________________________________________
>>> Mongrel-users mailing list
>>> Mongrel-users at rubyforge.org
>>> http://rubyforge.org/mailman/listinfo/mongrel-users
>>
>> _______________________________________________
>> Mongrel-users mailing list
>> Mongrel-users at rubyforge.org
>> http://rubyforge.org/mailman/listinfo/mongrel-users
>>
> _______________________________________________
> Mongrel-users mailing list
> Mongrel-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/mongrel-users



More information about the Mongrel-users mailing list