[Mongrel] fckeditor works, but i cant get my buttons back...

Zed Shaw zedshaw at zedshaw.com
Mon Sep 11 17:43:54 EDT 2006

On Mon, 2006-09-11 at 09:19 -0600, andrew wrote:
> >  -------Original Message-------
> >  From: Kirk Haines <wyhaines at gmail.com>
> >  Subject: Re: [Mongrel] fckeditor works, but i cant get my buttons back...
> >  Sent: Sep 11 '06 08:34
> >  

> Thanks. Sorry for such a basic question, but under mongrel_cluster.yml
> I have (obviously path to app is not literal):
> cwd: /path/to/app
> port: "8000"
> config: config/mongrel_mime.yml
> environment: production
> address:
> pid_file: log/mongrel.pid
> servers: 12
I'll have to try your config out, but use absolute paths for this stuff.
The relative paths were an oversite I'm trying to correct.

> I even tried dropping the config/ part.
> in the config/mongrel_mime.yml file i have:
> js: "text/javascript",
> xml: "text/xml"

I think you need to dump what is actually getting sent back to the
browser.  Until then you're just guessing. Check out:


And see what's really going on.

> I even tried what you literally pasted initally, and that still doesn't work.
> Is mime handling the job of the front end webserver aka apache2 with mod_proxy_balancer
> or should this really "just work"tm

Yeah, that's another thing, you probably need to get this working for
development, but in your production deployment you *really* do not want
Mongrel handling this.  It's such a waste of a perfectly good Apache

Zed A. Shaw
http://www.lingr.com/room/3yXhqKbfPy8 -- Come get help.

More information about the Mongrel-users mailing list