[Mongrel] fckeditor works, but i cant get my buttons back...

Kirk Haines wyhaines at gmail.com
Mon Sep 11 11:33:57 EDT 2006

On 9/11/06, andrew <andrew at sophrinix.com> wrote:

> in the config/mongrel_mime.yml file i have:
> js: "text/javascript",
> xml: "text/xml"
> I even tried what you literally pasted initally, and that still doesn't work.

Oh, I just cut and pasted that from lib/mongre/handelers.rb

> Is mime handling the job of the front end webserver aka apache2 with mod_proxy_balancer
> or should this really "just work"tm

I'm sleep and reading impaired today, so I didn't notice that you have
mongrel_cluster in the mix.  I'm pretty ignorant on mongrel_cluster,
so I don't know how that might complicate things.

However, in general, if mongrel is receiving your request for
/editorpath/fckeditor.js, it should be returning the file contents
with a mimetype of text/javascript or application/javascript (or even
application/x-javascript).  Now, your browser, when it runs this
javascript, will generate another request for
/editorpath/editor/fckeditor.html (probably with some query string
arguments attached to it, interestingly).  If that is returned to your
browser, too, then you should see the editor.

You can test this by using some tool to see what HTTP headers are
being sent when fckeditor.js is retreived.

wget -S http://servername.com/editorpath/fckeditor.js

is one way.

Make sure that the headers, and especially the content type look right.

Kirk Haines

More information about the Mongrel-users mailing list