[Mongrel] Multiple rails apps with Mongrel

zer0halo zerohalo at gmail.com
Fri Sep 8 12:55:40 EDT 2006

On 9/8/06, Zed Shaw <zedshaw at zedshaw.com> wrote:
> You can install the pre-release with:
> gem install mongrel --source=http://mongrel.rubyforge.org/releases/

Got it. Tx.  --prefix works now in that I can run by app at:


without any change in routes.rb

However, the Apache part still doesn't work. If I go to http://domain/app1,
I get nothing (no error, just blank). My log/development.log is empty which
means that Rails isn't even getting that far.

I believe that you just have to make sure the URI path
> (/app2/controller/action) gets passed back to the mongrel server as-is.
> Don't rewrite it, just route it.

I'm afraid you lost me here. How do I do that?

If you're not sure what apache is sending mongrel, run one mongrel with
> -B and go look at the log/mongrel_debug/files.log and
> log/mongrel_debug/rails.log for clues.

I checked the logs and the REQUEST_PATH and PATH_INFO are both logged as
/controller/action. I'm assmuing it should be  /app1/controller/action, and
that's the problem, but I don't know how to fix that. How?

"Impossible is nothing."
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/mongrel-users/attachments/20060908/d5fae4fe/attachment.html 

More information about the Mongrel-users mailing list