[Mongrel] works with webrick,lighty, not mongrel

Erik Morton eimorton at gmail.com
Tue Oct 31 14:37:42 EST 2006


In your application do you have a class called Sync with a method  
called send_qbxml? Mongrel uses Sync from the Ruby Std Lib. It looks  
to me that you have a name collision here.

Erik
On Oct 31, 2006, at 12:48 PM, Michael Fairchild wrote:

> Hello,
>   I've been working away to setup mongrel as my production server,  
> however I am running into an odd problem and am not sure where to  
> investigate for the answer.
>
>   When I run using mongrel_rails start most things work fine, but a  
> I get a few inexplicable undefined method errors, for example:
> undefined method `send_qbxml' for #The method is definitley there,  
> and can be accessed from console.  Further, I tried running with  
> webrick, and it worked as expected.  I tried lightty and it worked.
>
> I am hoping to both get this working, and understand why such an  
> error would occur.  Does anyone have any suggestions?
>
> Thanks a lot,
>
> Michael Fairchild
> _______________________________________________
> Mongrel-users mailing list
> Mongrel-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/mongrel-users



More information about the Mongrel-users mailing list