[Mongrel] win32-service weirdness

Luis Lavena luislavena at gmail.com
Fri Oct 20 12:54:08 EDT 2006


On 10/20/06, Dave Murphy <schwuk at gmail.com> wrote:
> I've got my application running under Windows with mongrel perfectly,
> so it was time to convert it to a service. service::install works
> fine, but service:start gives me some "One moment, start pending" and
> then lots of "One moment, stopped".
>

I have seen this... mongrel_service is too informative...

> After a bit of digging I found this in the service.log:
>
> ** Starting Mongrel in production mode at :3000
> ** Starting Rails in environment production ...
> c:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:123:in
> `const_missing': uninitialized constant Enum (NameError)
>         from c:/ruby/lib/ruby/gems/1.8/gems/rmagick-1.13.0-win32/lib/RMagick.rb:28
>         from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:33:in `require'
>         from c:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:147:in
> `require'
>         from c:/ruby/lib/ruby/gems/1.8/gems/gruff-0.2.4/lib/gruff/base.rb:18
>         from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
>         from c:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:147:in
> `require'
>         from c:/ruby/lib/ruby/gems/1.8/gems/gruff-0.2.4/lib/gruff.rb:3
>         from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:33:in `require'
>          ... 7 levels...
>         from c:/ruby/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3-mswin32/lib/mongrel.rb:750:in
> `initialize'
>         from c:/ruby/lib/ruby/gems/1.8/gems/mongrel_service-0.1/bin/mongrel_service:52:in
> `service_init'
>         from c:/ruby/lib/ruby/gems/1.8/gems/mongrel_service-0.1/bin/mongrel_service:153
>         from c:/ruby/bin/mongrel_service:18
>
> It's only the service that has a problem - running the app via mongrel
> works fine.
>

Other weirdness of mongrel_service. I wish could kill it right now, but can't.

This happens with all your rails applications? For what I see, rmagick
is used, please try in a service (rails app) without rmagick and check
if it work.

Also, what OS and SP are you using?
ruby? (official build, one-click installer, what).

> cheers,
> --
> Dave Murphy (Schwuk)
> http://schwuk.com
> _______________________________________________
> Mongrel-users mailing list
> Mongrel-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/mongrel-users
>


-- 
Luis Lavena
Multimedia systems
-
Leaders are made, they are not born. They are made by hard effort,
which is the price which all of us must pay to achieve any goal that
is worthwhile.
Vince Lombardi


More information about the Mongrel-users mailing list