[Mongrel] Mongrel Cluster init.d problems

Kyle Kochis kylekochis at gmail.com
Thu Nov 30 01:21:35 EST 2006


I have installed mongrel and mongrel_cluster fine and have them
running great with my app. I tried using the init.d script provided
with mongrel_cluster 2.1 to start it up on boot but it doesn't.
mongrel_cluster_ctl works fine for me by hand and so does
/etc/init.d./mongrel_cluster start. I am on Debian so I installed the
service links with sudo update-rc.d mongrel_cluster defaults. And yes
I chmod'ed it. I checked and double checked /etc/mongrel_cluster and
my yml file and everything I can think of. Finally out of frustration
I hand linked the system boot stuff like this:
sudo ln -s /etc/init.d/mongrel_cluster /etc/rc0.d/S84mongrel_cluster
sudo ln -s /etc/init.d/mongrel_cluster /etc/rc3.d/S84mongrel_cluster
sudo ln -s /etc/init.d/mongrel_cluster /etc/rc6.d/S84mongrel_cluster

And still no luck. Again if I start em up by hand everything works
like it should.

Thanks for the help,

Kyle


More information about the Mongrel-users mailing list