[Mongrel] [ANN] Mongrel Web Server 0.3.12 -- Pre-Release

Zed Shaw zedshaw at zedshaw.com
Tue Mar 28 10:01:06 EST 2006


Hey Rick, can you make sure you've got the very latest by uninstalling and
then re-installing?  I just added a few more exceptions that should get
stuffed if the client closes the socket.  Also, what browser and OS are you
on?  I'm guessing OSX right?

Zed


On 3/28/06 1:19 AM, "Rick Olson" <technoweenie at gmail.com> wrote:

> On 3/27/06, Zed Shaw <zedshaw at zedshaw.com> wrote:
>> Hello Everyone,
>> 
>> Mongrel is due for a 0.3.12 release which will feature some pretty insane
>> goodies for everyone.  There's talk of IOWA support, lots of speed
>> improvements (including sendfile support), a great Configurator which makes
>> configuring Mongrel a snap (especially for framework implementers), and a
>> ton of debugging stuff.
>
... 
> I did notice I was getting this in my mongrel log on each request:
> 
> Error accessing file: Broken pipe
> 
/opt/local/lib/ruby/gems/1.8/gems/mongrel-0.3.12/lib/mongrel/handlers.rb:182:i>
n
> `write'
> 
/opt/local/lib/ruby/gems/1.8/gems/mongrel-0.3.12/lib/mongrel/handlers.rb:182:i>
n
> `send_file'
> 
/opt/local/lib/ruby/gems/1.8/gems/mongrel-0.3.12/lib/mongrel/handlers.rb:182:i>
n
> `send_file'
> 
/opt/local/lib/ruby/gems/1.8/gems/mongrel-0.3.12/lib/mongrel/handlers.rb:201:i>
n
> `process'
> /opt/local/lib/ruby/gems/1.8/gems/mongrel-0.3.12/lib/mongrel/rails.rb:54:in
> `process'
> /opt/local/lib/ruby/gems/1.8/gems/mongrel-0.3.12/lib/mongrel.rb:402:in
> `process_client'
> /opt/local/lib/ruby/gems/1.8/gems/mongrel-0.3.12/lib/mongrel.rb:401:in
> `process_client'
> /opt/local/lib/ruby/gems/1.8/gems/mongrel-0.3.12/lib/mongrel.rb:466:in `run'
> /opt/local/lib/ruby/gems/1.8/gems/mongrel-0.3.12/lib/mongrel.rb:465:in `run'
> /opt/local/lib/ruby/gems/1.8/gems/mongrel-0.3.12/lib/mongrel.rb:455:in `run'
> /opt/local/lib/ruby/gems/1.8/gems/mongrel-0.3.12/lib/mongrel.rb:735:in `run'
> /opt/local/lib/ruby/gems/1.8/gems/mongrel-0.3.12/lib/mongrel.rb:733:in `run'
> /opt/local/lib/ruby/gems/1.8/gems/mongrel-0.3.12/bin/mongrel_rails:90:in `run'
> /opt/local/lib/ruby/gems/1.8/gems/mongrel-0.3.12/lib/mongrel/command.rb:163:in
> `run'
> /opt/local/lib/ruby/gems/1.8/gems/mongrel-0.3.12/bin/mongrel_rails:187
> /opt/local/bin/mongrel_rails:18
> 
> Everything still ran though.



More information about the Mongrel-users mailing list