[Mongrel] [mongrel] Mongrel says it works, but it doesn't

basaah baswilbers at gmail.com
Thu Jun 29 15:18:32 EDT 2006


On 6/29/06, Luis Lavena <luislavena at gmail.com> wrote:
>
> On 6/29/06, basaah <baswilbers at gmail.com> wrote:
> [snip]
> > > On both cases rexml show the warnings and errors about escaping
> > characters.
> >
> >
> > is that a problem then?
> >
> > > You're using the One Click Installer? which version?
> >
> >
> > 1.8.4  but  1.8.2 did the very same thing
> >
> > > What OS are you trying to run it?
> >
> >
> > microsoft windows xp proffesional
>
> Ok, open a console, type 'irb'
>
> into it, do a require 'rexml/entity'


first I got the same errors again...
so I uninstalled ruby
still had the .exe for 1.8.4. 17 rc2 or something on my desktop
installed again
¿and quess what?
It worked!!!
it returned true
now, also rubygems will also do remote instalations again (before I all had
to do it manual)
I'm now waiting for mongrel to install...
done installing woeh I hope it works....
aaargh errors...
no wait it just that the rails gem cannot be found.
let's install that then huh
oke that is installed, let's try again...
it gives this:
>mongrel_rails start
** Starting Mongrel listening at 0.0.0.0:3000
** Starting Rails with development environment ...
** Rails loaded.
** Loading any Rails specific GemPlugins
** Signals ready.  INT => stop (no restart).
** Mongrel available at 0.0.0.0:3000
** Use CTRL-C to stop.

looks good, now try firefox... and
damn STILL don't work..
aah I hoped it did.
let's try webrick, nope
maby trough 127.0.0.1:3000
WHAT it worked, but before reinstall of ruby this had no effect.
back to mongrel

SO tthank you very very very much
how simple it was, just an reinstall of ruby,
now I can test the speed differences for my own.


if the warnings shown here is the same during webrick/mongrel boot,
> then exist a problem with the xml parser, sometime that indicates your
> ruby installation is broken (somehow).
>
> my line #21 of C:\ruby\lib\ruby\1.8\rexml\entity.rb look like this:
>
>                 ENTITYDECL = /\s*(?:#{GEDECL})|(?:#{PEDECL})/um
>
> I don't use One-Click, so that's why I have it installed in ruby/1.8
> instead of site_ruby/1.8
>
>
>
> > I have Suse linux on my comp as well but by linux knowledge is just to
> low
> > to install mongrel
> > I  tried but rubygems sais it needed 1.8.4 of ruby, so I managed to
> instal
> > that version, but then rubygems was gone and I didn't manage to install
> a
> > new rubygems.
> >
>
> No problem, my knowledge on suse/yast distros is almost nonexistent.
>
> >
> > thank you for your relpy
> >
>
> No problem, hope we get to the root of this problem.


and we got it Ruby itself was the root

--
> Luis Lavena
> Multimedia systems
> -
> Leaders are made, they are not born. They are made by hard effort,
> which is the price which all of us must pay to achieve any goal that
> is worthwhile.
> Vince Lombardi
> _______________________________________________
> Mongrel-users mailing list
> Mongrel-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/mongrel-users
>



-- 
<<{{}}[]greetings bas[]{{}}>>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/mongrel-users/attachments/20060629/3cd91e41/attachment.html 


More information about the Mongrel-users mailing list