[Mongrel] [mongrel] Mongrel says it works, but it doesn't

Luis Lavena luislavena at gmail.com
Thu Jun 29 14:09:56 EDT 2006

On 6/29/06, basaah <baswilbers at gmail.com> wrote:
> > On both cases rexml show the warnings and errors about escaping
> characters.
> is that a problem then?
> > You're using the One Click Installer? which version?
> 1.8.4  but  1.8.2 did the very same thing
> > What OS are you trying to run it?
> microsoft windows xp proffesional

Ok, open a console, type 'irb'

into it, do a require 'rexml/entity'

if the warnings shown here is the same during webrick/mongrel boot,
then exist a problem with the xml parser, sometime that indicates your
ruby installation is broken (somehow).

my line #21 of C:\ruby\lib\ruby\1.8\rexml\entity.rb look like this:

		ENTITYDECL = /\s*(?:#{GEDECL})|(?:#{PEDECL})/um

I don't use One-Click, so that's why I have it installed in ruby/1.8
instead of site_ruby/1.8

> I have Suse linux on my comp as well but by linux knowledge is just to low
> to install mongrel
> I  tried but rubygems sais it needed 1.8.4 of ruby, so I managed to instal
> that version, but then rubygems was gone and I didn't manage to install a
> new rubygems.

No problem, my knowledge on suse/yast distros is almost nonexistent.

> thank you for your relpy

No problem, hope we get to the root of this problem.

Luis Lavena
Multimedia systems
Leaders are made, they are not born. They are made by hard effort,
which is the price which all of us must pay to achieve any goal that
is worthwhile.
Vince Lombardi

More information about the Mongrel-users mailing list