[Mongrel] Gem versioning and auto installs

Neil Wilson neil at aldur.co.uk
Sat Jun 3 17:27:10 EDT 2006


On 03/06/06, Zed Shaw <zedshaw at zedshaw.com> wrote:
>
> You've got two options at the moment:
>
> 1) Manually grab the version you want and then install the gem file.
> I'd do it like this:
>
>        $ wget \
> http://rubyforge.org/frs/download.php/9700/mongrel-0.3.12.4.gem
>        $ gem install mongrel-0.3.12.4.gem



Tried that - local gem install doesn't handle dependencies automatically :-(

Not at all keen on pre-release for various reasons.

The third option is this ugly hack that I cobbled together this afternoon
right before I ran out of hair to pull out. Those with a weak stomach should
look away now.

sudo sh -c "gem install mongrel -v 0.3.12.4 </dev/null 2>&1|
    sed -ne '/(ruby)/s/ \([0-9][0-9]*\).*/\1/p' |
    gem install -y --no-rdoc -v 0.3.12.4 mongrel"




-- 
Neil Wilson (neil at aldur.co.uk)
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/mongrel-users/attachments/20060603/dc174c9d/attachment.htm 


More information about the Mongrel-users mailing list