[Mongrel] Gem versioning and auto installs

Zed Shaw zedshaw at zedshaw.com
Sat Jun 3 16:59:25 EDT 2006


On Sat, 2006-06-03 at 09:02 +0100, Neil Wilson wrote:
> Gem drives me daft sometimes.
> 
> It gives you this wonderful ability to specify a platform for a gem,
> but forgets to provide a command line switch to select the platform.
> Politely it asks you, which is all very well when you are installing
> on one machine interactively, but no good at all on a cluster of 15
> machines from a Capistrano script.
> 
> Is there any way to get gem to automatically select the correct
> platform for a particular version of Mongrel?
> 
> Failing that can I respectively request slightly different version
> numbers for the differing platforms to assist automatic installs.

You've got two options at the moment:

1) Manually grab the version you want and then install the gem file.
I'd do it like this:

	$ wget \
 http://rubyforge.org/frs/download.php/9700/mongrel-0.3.12.4.gem
	$ gem install mongrel-0.3.12.4.gem

2) Install the pre-release.  This is always just one version.  It's
released fairly frequently but we try to keep it stable.  You can do
this with:

	$ gem install mongrel --source=http://mongrel.rubyforge.org/releases/


If neither of these are good, and other people would like to just
install the current version without a prompt, then I can setup
a /current/ gem source that's like /releases/ but it just contains the
current production release.  But, at least try the other two options
before making me do work. :-)


-- 
Zed A. Shaw
http://www.zedshaw.com/
http://mongrel.rubyforge.org/




More information about the Mongrel-users mailing list