[Mongrel] Rubygems 0.9.0.8 and Fastthread problem

MenTaLguY mental at rydia.net
Wed Dec 27 00:48:02 EST 2006


On Tue, 2006-12-26 at 19:43 -0300, Luis Lavena wrote:
> I guess rubygems folks added thread part of rubygems now... something
> that isn't good at all (why I require thread if my application I don't
> use it?, just to say something).

I don't know... it seems reasonable if they need to do something in a
threadsafe manner.  Even e.g. Singleton needs synchronization, though it
doesn't currently use Mutex to do it (IMO it _should_, fastthread
weirdness aside).

I'm not really sure what the best resolution here is.  fastthread is
ultimately intended to become a patch to Ruby core, of course.  But that
can't happen immediately, especially as even with the patch in hand I
would still need to sell the ruby-core folks on it...

-mental
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part
Url : http://rubyforge.org/pipermail/mongrel-users/attachments/20061227/4c2bf699/attachment.bin 


More information about the Mongrel-users mailing list