[Mongrel] [ANN] fastthread 0.5.3

Ezra Zygmuntowicz ezmobius at gmail.com
Fri Dec 22 13:32:43 EST 2006


On Dec 22, 2006, at 1:48 AM, Mark Somerville wrote:

> On Saturday 16 December 2006 19:48, MenTaLguY wrote:
>> Unless someone finds more bugs, this version of fastthread will
>> eventually become 1.0.
>
> I don't know if this is a fastthread, mongrel or gems problem - it  
> might not
> even be a problem!
>
> Since upgrading to fastthread 0.5.3.1 and mongrel 1.0RC1, I get a
> message - "fastthread not loaded: fastthread must be required before
> thread" - when starting my DRb upload server (detailed here:
> http://mongrel.rubyforge.org/docs/upload_progress.html). "require  
> 'fastthread'"
> doesn't seem to alter anything. I haven't had time to fully check  
> it out, but
> everything still appears to function alright, at least on my  
> development box.
>
> Can anyone explain what's happening? How can I fix it, if I need to?
>
> Cheers,
>
> Mark


Mark-

	When you require 'drb' drb in turn requires thread. If you are using  
fastthread you must require it before thread gets required thats just  
the way it works. So in your drb server code file you need to do this:

require 'rubygems'
require 'fastthread'
then require drb and anything else you need.
	
Cheers-
-- Ezra Zygmuntowicz 
-- Lead Rails Evangelist
-- ez at engineyard.com
-- Engine Yard, Serious Rails Hosting
-- (866) 518-YARD (9273)




More information about the Mongrel-users mailing list