[Mongrel] running mongrel in production on win32

frazer horn frazer.list at gmail.com
Tue Dec 19 16:28:45 EST 2006


Luis

I am using your latest build of mongrel service in production with your
latest build of mongrel from your site too.  Everything is running really
well.

Do you have a build of fastthread for windows yet?  Will fastthread even be
available for win32?

Thanks for all the excellent work

Fraz

On 12/19/06, Luis Lavena <luislavena at gmail.com> wrote:
>
> On 12/19/06, Michael D'Auria <michael.dauria at gmail.com> wrote:
> > You should upgrade to the newest version: 0.3.20 as it allows multiple
> > Set-Cookie header statements.
> >
> > For reference:http://mongrel.rubyforge.org/news.html
> >
> > To Install:
> > $ gem install fastthread
> > --source=http://mongrel.rubyforge.org/releases
> > $ gem install mongrel
> > --source=http://mongrel.rubyforge.org/releases
> >
> > Then you should be back on track :)
> >
> > .: Michael :.
> >
>
> The gems available in the mongrel.rubyforge.org/releases are ONLY
> source, which requires a compiler.
>
> The problem in mswin32 is that compilers compatible with ruby are only
> VC6, which also requires you purchased it.
>
> I'll upadte the gem in my webserver tonight and put a mail on the list
> (AFAIK, Zed already modified to allow multiple cookies).
>
> >
> > On 12/19/06, Ball, Donald A Jr (Library) <donald.ball at nashville.gov>
> wrote:
> > > > Sure. Actually, I have a problem to report already...
> > > > sessions are not working when I start mongrel in this
> > > > fashion. Is there somewhere i should be configuring session
> > > > behavior that I'm not?
> > > >
> > > > To be more specific, the browser doesn't report a session_id
> > > > cookie in its cookie list. The server-side code happily
> > > > stores objects in the session, but the session is empty on
> > > > the next request.
> > > >
> > > > For the record, both webrick and mongrel started via
> > > > script/server have working sessions.
> > >
> > > The problem turns out to be fairly simple, but it's beyond my
> capability
> > > to fix. The problem is that mongrel is only passing one and only one
> > > cookie on to the user. If that's _session_id, great, but if it's one
> of
> > > the other cookies that I'm creating, the user's session is lost.
> > >
> > > To be clear, I'm using mongrel-0.3.18 from Luis. Note that I was
> > > incorrect when I said the problem didn't occur when mongrel is stared
> > > with script\server. Mongrel has this problem regardless, while webrick
> > > works fine.
> > >
> > > - donald
> > > _______________________________________________
> > > Mongrel-users mailing list
> > > Mongrel-users at rubyforge.org
> > > http://rubyforge.org/mailman/listinfo/mongrel-users
> > >
> >
> >
> > _______________________________________________
> > Mongrel-users mailing list
> > Mongrel-users at rubyforge.org
> > http://rubyforge.org/mailman/listinfo/mongrel-users
> >
> >
>
>
> --
> Luis Lavena
> Multimedia systems
> -
> Leaders are made, they are not born. They are made by hard effort,
> which is the price which all of us must pay to achieve any goal that
> is worthwhile.
> Vince Lombardi
> _______________________________________________
> Mongrel-users mailing list
> Mongrel-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/mongrel-users
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/mongrel-users/attachments/20061219/377b327d/attachment-0001.html 


More information about the Mongrel-users mailing list