[Mongrel] running mongrel in production on win32

Joey Geiger jgeiger at gmail.com
Tue Dec 19 13:13:37 EST 2006


This is something I mentioned on here to Zed, and he said it will be
fixed coming up with the next release.

I do know that 0.3.14 works, which I believe was the last stable
release for ruby (and 0.3.13 which was the windows stable release?)

On 12/19/06, Ball, Donald A Jr (Library) <donald.ball at nashville.gov> wrote:
> > Sure. Actually, I have a problem to report already...
> > sessions are not working when I start mongrel in this
> > fashion. Is there somewhere i should be configuring session
> > behavior that I'm not?
> >
> > To be more specific, the browser doesn't report a session_id
> > cookie in its cookie list. The server-side code happily
> > stores objects in the session, but the session is empty on
> > the next request.
> >
> > For the record, both webrick and mongrel started via
> > script/server have working sessions.
>
> The problem turns out to be fairly simple, but it's beyond my capability
> to fix. The problem is that mongrel is only passing one and only one
> cookie on to the user. If that's _session_id, great, but if it's one of
> the other cookies that I'm creating, the user's session is lost.
>
> To be clear, I'm using mongrel-0.3.18 from Luis. Note that I was
> incorrect when I said the problem didn't occur when mongrel is stared
> with script\server. Mongrel has this problem regardless, while webrick
> works fine.
>
> - donald
> _______________________________________________
> Mongrel-users mailing list
> Mongrel-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/mongrel-users
>


More information about the Mongrel-users mailing list