[Mongrel] windows service auto start problems

Shawn Hill shawn at brmethod.com
Wed Dec 13 15:11:38 EST 2006

I am not sure about your stack, but the following fixed this problem for for

For each of you mongrel services:
In services panel:
set startup type to automatic
Under recovery tab, Set 1st and 2nd failure to restart 

In regedit:
under My
right click and add a new string value "DependOnService" set it to "IIS
Admin Service"

If you are using Apache or lighty, set it to the service name for that web

Shawn Hill
shawn at hillacious.com

-----Original Message-----
From: mongrel-users-bounces at rubyforge.org
[mailto:mongrel-users-bounces at rubyforge.org] On Behalf Of Mark Roghelia
Sent: Friday, December 08, 2006 3:21 PM
To: mongrel-users at rubyforge.org
Subject: [Mongrel] windows service auto start problems

I have a small Rails app deployed on Windows Server 2003 and Mongrel  Everything works well, except when the Windows box is rebooted.
I have mongrel_service installed and the service is configured to start
automatically, however Mongrel consistently fails to start after a reboot.
Windows reports the service's status as "Started", but attempts to access
the app fail and checking Task Manager reveals there is no ruby process
running.  If I manually stop and start the service at that point everything
comes up fine.  I don't see anything of note in any of the log files in the
Rails "log"  
directory, or in the Event Viewer.

Has anyone else seen this kind of behavior?  If so, do you have any
suggestions about how to work around it?

I understand that work is currently being done to retool mongrel_service.
Is this possibly a known issue and something that is being addressed?


Mark Roghelia

Mongrel-users mailing list
Mongrel-users at rubyforge.org

More information about the Mongrel-users mailing list