[Mongrel] windows service auto start problems

Luis Lavena luislavena at gmail.com
Fri Dec 8 19:30:05 EST 2006

On 12/8/06, Mark Roghelia <mroghelia at topsailtech.com> wrote:
> I have a small Rails app deployed on Windows Server 2003 and Mongrel
>  Everything works well, except when the Windows box is
> rebooted.  I have mongrel_service installed and the service is
> configured to start automatically, however Mongrel consistently fails
> to start after a reboot.  Windows reports the service's status as
> "Started", but attempts to access the app fail and checking Task
> Manager reveals there is no ruby process running.  If I manually stop
> and start the service at that point everything comes up fine.  I
> don't see anything of note in any of the log files in the Rails "log"
> directory, or in the Event Viewer.
> Has anyone else seen this kind of behavior?  If so, do you have any
> suggestions about how to work around it?

Yes, that behavior happens if mongrel_service tries to start prior the
network stack get up (it fails to bind to tcp/ip).

> I understand that work is currently being done to retool
> mongrel_service.  Is this possibly a known issue and something that
> is being addressed?

This is something that current and new implementation lack of solution.

I'm reworking ServiceFB framework to allow complete control of service
dependencies and make it "start" after all network services are up, to
solve this issue.

Luis Lavena
Multimedia systems
Leaders are made, they are not born. They are made by hard effort,
which is the price which all of us must pay to achieve any goal that
is worthwhile.
Vince Lombardi

More information about the Mongrel-users mailing list