[Mongrel] Mongrel and Mongrel Cluster Library LoadErrors

kigsteronline at mac.com kigsteronline at mac.com
Mon Dec 4 14:50:32 EST 2006


You may need to check your LD_LIBRARY_PATH variable.   My guess is  
that Oracle OCI library lives somewhere where oracle is installed  
($ORACLE_HOME/lib).  So I would try to make sure that when mongrel  
starts, LD_LIBRARY_PATH and ORACLE_HOME are setup correctly in  
mongrel's environment.

Hope this helps
Konstantin


On Dec 4, 2006, at 10:48 AM, Phillip Novess wrote:

> Hello,
>
> I'm a noobie to Rails and even more to mongrel. I have an issue  
> with one server that I've installed mongrel. Its a Fedora Core 5  
> box, and it is having problems loading the Oracle OCI8 libraries.   
> However, this only occurs when I use mongrel_cluster, or mongrel  
> with out the -d switch.  I have no problem using the library from  
> the commandline and with Webrick or mongrel whn I use the -d  
> switch.  The other perplexing thing is I have mongrel_cluster  
> working on another server that runs Fedora Core 4. I upgraded that  
> box with Fedora Core 5 and it still works correctly.  But the other  
> server is a clean install of Fedora Core 5 and no joy.
>
> Does anybody have an idea what to check or add so that this will  
> work correctly? I suspect permissions or environment variables are  
> the problem, but how would I know?
>
> Thanks,
> Phill
>
>
> _______________________________________________
> Mongrel-users mailing list
> Mongrel-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/mongrel-users



More information about the Mongrel-users mailing list