[Mongrel] "Broken pipe" and "no such file to load -- irb"

Evan White evanbwhite at gmail.com
Mon Aug 28 22:45:28 EDT 2006


I just switched my rails app, which I had previously been running on my pc,
to my linux server and have decided to use mongrel.  However, since doing so
I get an error when I first access the app saying "no such file to load --
irb".  After I refresh this error goes away, but I keep getting the
following errors in my logs, and I've noticed that certains things, like
sessions and redirects, aren't working.

Any idea why this might be?
~Evan

Logfile errors:

Error sending file /home/evan/rails3/public/javascripts/prototype.js: Broken
pi\
pe
Error calling Dispatcher.dispatch #<MissingSourceFile: no such file to load
-- \
irb>
/usr/lib/site_ruby/1.8/rubygems/custom_require.rb:27:in
`gem_original_require'
/usr/lib/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
/usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1
/lib/active_support/dependencies\
.rb:147:in `require'
/usr/lib/ruby/gems/1.8/gems/rails-1.1.6/lib/breakpoint.rb:18
/usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1
/lib/active_support/dependencies\
.rb:140:in `load'
/usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1
/lib/active_support/dependencies\
.rb:56:in `require_or_load'
/usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1
/lib/active_support/dependencies\
.rb:30:in `depend_on'
/usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1
/lib/active_support/dependencies\
.rb:85:in `require_dependency'
/usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1
/lib/active_support/dependencies\
.rb:98:in `const_missing'
/usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1
/lib/active_support/dependencies\
.rb:131:in `const_missing'
/usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1
/lib/active_support/dependencies\
.rb:133:in `const_missing'
/usr/lib/ruby/gems/1.8/gems/rails-1.1.6/lib/dispatcher.rb:75:in
`reset_after_di\
spatch'
/usr/lib/ruby/gems/1.8/gems/rails-1.1.6/lib/dispatcher.rb:46:in `dispatch'
/usr/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3/lib/mongrel/rails.rb:73:in`proces\
s'
/usr/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3/lib/mongrel.rb:551:in`process_cli\
ent'
/usr/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3/lib/mongrel.rb:550:in`process_cli\
ent'
/usr/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3/lib/mongrel.rb:636:in `run'
/usr/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3/lib/mongrel.rb:636:in `run'
/usr/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3/lib/mongrel.rb:625:in `run'
/usr/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3/lib/mongrel.rb:956:in `run'
/usr/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3/lib/mongrel.rb:955:in `run'
/usr/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3/bin/mongrel_rails:127:in `run'
/usr/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3/lib/mongrel/command.rb:199:in`run\
'
/usr/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3/bin/mongrel_rails:235
/usr/bin/mongrel_rails:18
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/mongrel-users/attachments/20060828/ca8937f5/attachment-0001.html 


More information about the Mongrel-users mailing list