[Mongrel] restart - `exec': Operation not supported

Jason A. Hoffman jason at joyent.com
Mon Aug 28 20:28:36 EDT 2006


On Aug 28, 2006, at 5:15 PM, Joe Ruby wrote:
> I'm using the latest Mongrel (0.3.13.4) and restarting
> causes Mongrel to die. From mongrel.log:
>
> ** USR2 signal received.
> ** Restarting with arguments:  ruby
> /opt/local/lib/ruby/gems/1.8/gems/mongrel-0.3.13.4/bin/mongrel_rails
> start -C config/mongrel.yml
> /opt/local/lib/ruby/gems/1.8/gems/mongrel-0.3.13.4/bin/ 
> mongrel_rails:142:in
> `exec': Operation not supported - ruby
> /opt/local/lib/ruby/gems/1.8/gems/mongrel-0.3.13.4/bin/mongrel_rails
> start -C config/mongrel.yml (Errno::EOPNOTSUPP)
>         from
> /opt/local/lib/ruby/gems/1.8/gems/mongrel-0.3.13.4/bin/ 
> mongrel_rails:142:in
> `run'
>         from
> /opt/local/lib/ruby/gems/1.8/gems/mongrel-0.3.13.4/lib/mongrel/ 
> command.rb:203:in
> `run'
>         from
> /opt/local/lib/ruby/gems/1.8/gems/mongrel-0.3.13.4/bin/ 
> mongrel_rails:231
>         from /opt/local/bin/mongrel_rails:18
>
> I tried 'ruby
> /opt/local/lib/ruby/gems/1.8/gems/mongrel-0.3.13.4/bin/mongrel_rails
> start -C config/mongrel.yml' from the commandline and
> it started up Mongrel.
>
> Joe

What operating system is this? And did it install properly? /opt/ 
local/lib/ruby/gems/1.8/gems/mongrel-0.3.13.4/bin/mongrel_rails isn't  
where it should be, from that I'd think it would be at /opt/local/bin/ 
mongrel_rails?

- Jason


More information about the Mongrel-users mailing list