[Mongrel] BAD CLIENT, Invalid HTTP Format - Firefox, IE, etc..

Ross Singer ross.singer at library.gatech.edu
Sun Aug 27 15:26:16 EDT 2006


Eoin,

I think the first step was:
get the latest 0.3.13.4 pre-release:  gem install mongrel
--source=http://mongrel.rubyforge.org/releases/

-Ross.

On 8/27/06, Eoin Curran <eoin at peelmeagrape.net> wrote:
> Also getting this error message - was trying to enable request logging
> as described at:
>
> http://www.mail-archive.com/mongrel-users@rubyforge.org/msg01018.html
>
> But I just get
> /usr/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3/lib/mongrel.rb:982:in
> `join': SIGUSR1 (SignalException)
>         from
> /usr/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3/lib/mongrel.rb:982:in `join'
>         from
> /usr/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3/lib/mongrel.rb:982:in `join'
>         from
> /usr/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3/bin/mongrel_rails:136:in `run'
>         from
> /usr/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3/lib/mongrel/command.rb:199:in
> `run'
>         from
> /usr/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3/bin/mongrel_rails:235
>         from /usr/bin/mongrel_rails:18
>
> Looking through the source, the USR1 signal isn't trapped. Should I be
> using a different version to get this request logging?
>
> thanks,
> eoin.
>
> _______________________________________________
> Mongrel-users mailing list
> Mongrel-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/mongrel-users
>


More information about the Mongrel-users mailing list