[Mongrel] really a GemPlugin/mongrel_cluster question

Asa Hopkins asa at caltech.edu
Fri Aug 25 18:08:49 EDT 2006


Hi folks,

I'd like to run the Mongrel prerelease (0.3.13.4 prerelease) and  
mongrel_cluster 0.2.1 on my shared host (which doesn't want to  
install prerelease software for all to use).  I can install the gems  
in my own directory, and run mongrel 0.3.13.4 with --prefix just  
fine.  However, I think due to the GemPlugin structure, even my new  
mongrel_rails loads up mongrel_cluster 0.2.0, which doesn't support -- 
prefix.  If I try telling rubygems to ignore the other installed gems  
(in the main gem structure), it loses track of itself (gem  
environment fails, for example).

Ideas?

Thanks,
Asa

-----------------
Work is love made visible
-----------------
Asa S. Hopkins
MC 266-33, Pasadena, CA 91125
asa at caltech.edu
http://www.its.caltech.edu/~asa/
-----------------


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/mongrel-users/attachments/20060825/b3f88431/attachment-0001.html 


More information about the Mongrel-users mailing list