[Mongrel] mongrel logging on win32 platform and win32 service

linux user fanoflinux at gmail.com
Fri Aug 25 11:57:48 EDT 2006

On 8/25/06, Luis Lavena <luislavena at gmail.com> wrote:
> On 8/25/06, linux user <fanoflinux at gmail.com> wrote:
> [snip]
> >
> > Luis
> >
> > I tried this too an fresh rails application and use the following
> command to
> > start mongrel
> >
> > mongrel_rails start -c C:/temp/snap -e production
> >
> > the only log file I get in the log folder are
> > development.log
> > mongrel_debug\files.log
> > production.log
> > server.log
> > test.log
> >
> Before start rails you removed the empty logs? (the ones rails created
> by default).
> If they get created again, mongrel should be logging there, check
> production.log for a the timestamp of the last logged event (after you
> hit your webbrowser).
> > and BTW I also re-installed mongrel win32 and mongrel-service
> but
> > still no solution.
> >
> > I am begining to think its platform related Win2K SP4, I don't have
> access
> > to XP. May be I need to re-install ruby & rails ?? but that would be
> > ridiculous.
> >
> I have installed ruby, One-Click-Installer and plain ruby-mswin32 on
> XP (SP1&SP2), W2K SP3 and SP4 and W2K3 Server, all without problems.
> --
> Luis Lavena
> Multimedia systems
> -
> Leaders are made, they are not born. They are made by hard effort,
> which is the price which all of us must pay to achieve any goal that
> is worthwhile.
> Vince Lombardi
> _______________________________________________
> Mongrel-users mailing list
> Mongrel-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/mongrel-users


 I should have checked the timestamp of production.log last time when I
started mongrel -e production.

Thanks I think I have solved the problem and I have found the conflicting
option, but I have no decent explaination for it. Here is what I did

1. In my original application I deleted all log file and mongrel_debug
folder and restarted mongrel

in my config/environment/production.rb I have
config.log_level = :debug
config.log_path = 'log/production_debug.log'

At this time the log folder has only one log file 'production_debug.log' and
folder 'mongrel_debug' with 'files.log'. So I get all the output from logger
(at debug level) in 'log/production_debug.log'.

But I still get the output from 'puts, p, print' on the console and nowhere
in any log file.

2. If I remove the logger configuration from my
config/environments/production.rb, I still get output from 'puts, p, print'
on the console. The only content on production.log at this time is (mostly
Processing SnapshotController#print_letters (for at 2006-08-25
10:51:17) [GET]
  Session ID: 022a23172e2328c2ba29f36a65e1ecbe
  Parameters: {"action"=>"print_letters", "controller"=>"snapshot"}
Redirected to http://localhost:4111/snapshot/letter/list
Completed in 0.00010 (10000 reqs/sec) | DB: 0.00000 (0%) | 302 Found [

I still need to capture the output on console to a log file, don't know how
to do it.

Are you able to capture output from 'puts, p, print' on the console to a log

thanx a megaton for helping me.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/mongrel-users/attachments/20060825/20582c2f/attachment-0001.html 

More information about the Mongrel-users mailing list