[Mongrel] mongrel logging on win32 platform and win32 service

linux user fanoflinux at gmail.com
Fri Aug 25 11:07:29 EDT 2006


On 8/25/06, Luis Lavena <luislavena at gmail.com> wrote:
>
> On 8/25/06, linux user <fanoflinux at gmail.com> wrote:
> [snip]
> > > > No these files are not there.
> > > >
> > > > I tried to locate mongrel.log in production.log, but its not there.
> I
> > only
> > > > have log/production.log but that was created by rails script when
> the
> > > > application root was created and log/production.log is 0KB after
> load
> > > > testing mongrel for 1 hour.
> > > >
> > > > I am on Windows 2000 SP4.
> > > >
> > > > please help
> > >
> > > Daya, first of: post this to one mailing list, do not "cross-post" to
> > > rails and mongrel, the correct place, in this case, is mongrel one.
> > >
> > > Now, why you don't try the following?
> > >
> > > open a Command prompt window.
> > > C:
> > > cd C:\myspace\snapshot
> > > mongrel_rails start -e production
> > >
> > > wait until it is running... now check using windows explorer for
> > > log/*.log files inside that folder.
> > >
> > > They should be there, I see them here when running in my app, with
> > > both prerelease and stable.
> >
> >
> >
> > Hi Luis
> >
> > I just tried your suggestion and although mongrel starts at port 3000 by
> > default the logs are still not created. I did a full scan of application
> > root for *.log and there are no log files that are created by mongrel.
> >
> > I also tried running mongrel -B (debug) option and now I get in
> > log/mongrel_debug folder files.log, objects.log, params.log, rails.logand
> > thread.log, these as we know are not the logs I am interested in.
> >
> > I had installed mongrel through gems and since I didn't include
> > --include-dependencies at that time, the installation process prompted
> me to
> > select which mongrel I wanted installed I selected the first option for
> > win32 which was 0.3.13.3. May be I need to re-install mongrel?
> >
> > I appreciate your help but I am lost in this simple problem.
> >
>
> Ok Daya,
>
> I tried the same here, with a empty rails application and with a working
> one.
>
> my logs are created, on development or production environment...
>
> Please, start a fresh rails application, set the database and clear
> the log folder (delete *.log from there). Start mongrel with the same
> sentence I put previously and check the logs created.
>
> If they got created, is somehow your application, if not... too weird
> for friday...
>
> --
> Luis Lavena
> Multimedia systems
> -
> Leaders are made, they are not born. They are made by hard effort,
> which is the price which all of us must pay to achieve any goal that
> is worthwhile.
> Vince Lombardi
> _______________________________________________
> Mongrel-users mailing list
> Mongrel-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/mongrel-users
>

Luis

I tried this too an fresh rails application and use the following command to
start mongrel

mongrel_rails start -c C:/temp/snap -e production

the only log file I get in the log folder are
development.log
mongrel_debug\files.log
production.log
server.log
test.log

and BTW I also re-installed mongrel 0.3.13.3 win32 and mongrel-service but
still no solution.

I am begining to think its platform related Win2K SP4, I don't have access
to XP. May be I need to re-install ruby & rails ?? but that would be
ridiculous.

-daya
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/mongrel-users/attachments/20060825/3a1a839b/attachment-0001.html 


More information about the Mongrel-users mailing list