[Mongrel] Mongrel and Service behave differently

David Benjamin david at splinter.com
Wed Aug 23 04:21:39 EDT 2006


Zed Shaw wrote:
> On Tue, 2006-08-22 at 06:05 -0700, Jay Turpin wrote:
>   
>> I have a rails application running under the latest version of Mogrel
>> Win32. Seems to run just fine. However, when I attempt to run it under
>> the Win32 Mongrel service, it appears to hand after hitting certain
>> controller actions. I'm sure there is a bug in my code that's causing
>> this - but I just am not sure what it is yet. 
>>
>> Is there anything about the mongrel-service that would cause an
>> application to behave differently? Besides the -B option to turn on
>> debugging, are there any other tricks for me to get visibility to what
>> is going on underneath the covers? 
>>
>> If I can't track down this issue, is there any to using mongrel_rails
>> from a scheduler instead of the service?
>>     
>
> Hey Jay,
>
> Yeah actually the win32-service stuff has a few bugs that Dan Berger has
> fixed.  I'll be cooking up a new gem for him soon and hopefully working
> with him to get all his stuff "gemified".
>
> Until then, can you look for exception reports in your logs and send
> them to me (off-list).  Thanks.
>
>
>   

Hi Jay,

We also had difficulties with opaque "Application Error" screens on some of
our controller actions and not others when running as a service.  The 
only hammer
I have to hit this screen is permission problems, so we edited the service
"Properties -> Log On -> Log on as: " property
to be a different, slightly more powerful, but not too powerful, account.
This may only help you if your app is accessing files and other
windows resources.

Sorry to not be more specific, we're not exactly sure whats aggravating
using the default service settings either.  You're question was a good one.

The win32 support is much appreciated, thanks a lot Luis Lavena!

Dave



More information about the Mongrel-users mailing list