[Mongrel] Problem getting Mongrel to start at startup

Nick Snels nick.snels at gmail.com
Tue Aug 22 06:56:00 EDT 2006


I found the problem. I had ruby installed from source and it ended up in
/usr/local/bin, so I had to create the following extra symbolic links to get
it working.

ln -s /usr/local/bin/ruby /usr/bin/ruby
ln -s /usr/local/bin/mongrel_cluster_ctl /usr/bin/mongrel_cluster_ctl
ln -s /usr/local/bin/mongrel_rails /usr/bin/mongrel_rails

Kind regards,


On 8/22/06, Nick Snels <nick.snels at gmail.com> wrote:
> Hi,
> I'm running CentOS 4.3 and the latest Mongrel ( and
> mongrel_cluster (0.2.0). I have set up a cluster, following the
> instructions at http://mongrel.rubyforge.org/docs/mongrel_cluster.html . I
> created a symbolic link in the directory /etc/mongrel_cluster . When I run
> mongrel_rails cluster::start -c test.yml, the mongrel servers start up.
> But at boot, the command '/sbin/service mongrel_cluster start' gets run,
> when I run it I get the error:
> Starting all mongrel_clusters...
> /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27: command
> not found: mongrel_rails cluster::start -c test.yml
> mongrel_rails cluster::start returned an error.
> I have tried many things, but nothing works. I hope somebody can help me
> out. Thanks.
> Kind regards,
> Nick
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/mongrel-users/attachments/20060822/9910c456/attachment.html 

More information about the Mongrel-users mailing list