[Mongrel] Problem getting Mongrel to start at startup

Nick Snels nick.snels at gmail.com
Tue Aug 22 05:58:51 EDT 2006


Hi,

I'm running CentOS 4.3 and the latest Mongrel (0.3.13.3) and mongrel_cluster
(0.2.0). I have set up a cluster, following the instructions at
http://mongrel.rubyforge.org/docs/mongrel_cluster.html . I created a
symbolic link in the directory /etc/mongrel_cluster . When I run
mongrel_rails cluster::start -c test.yml, the mongrel servers start up. But
at boot, the command '/sbin/service mongrel_cluster start' gets run, when I
run it I get the error:

Starting all mongrel_clusters...
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27: command not
found: mongrel_rails cluster::start -c test.yml
mongrel_rails cluster::start returned an error.

I have tried many things, but nothing works. I hope somebody can help me
out. Thanks.

Kind regards,

Nick
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/mongrel-users/attachments/20060822/37b9a021/attachment-0001.html 


More information about the Mongrel-users mailing list