[Mongrel] Mongrel setting with Mysql error

Zed Shaw zedshaw at zedshaw.com
Fri Aug 18 15:56:20 EDT 2006


On Fri, 2006-08-18 at 10:12 -0400, Guillaume Carbonneau wrote:
> Hi,
>  
> I'm pretty newb at Rails deployement stuff.
> I'm setting up a Mongrel web server on windows following the tutorial
> on the official site.
> My app works except when there's interaction with MySQL. I get this
> error :
>  
> "Uninitialized constant Mysql"
>  
> Now i'm pretty lost and i'm sure i'm doing something wrong. I've tried
> searching google, ruby and rails mailing list but didn't find
> anything.
> I'd appreciate if you guys could point me to the right direction. Like
> what steps I have to do to make mysql interact with Mongrel/Ruby.
>  

Haven't seen this from people who use win32, so I'm thinking your setup is wrong somehow.

Have you tried installing the win32 mysql gem?

gem install mysql

I believe that'll intall it but you have to pick win32.  If you've
already done this then maybe remove it and see if you get the error.


-- 
Zed A. Shaw
http://www.zedshaw.com/
http://mongrel.rubyforge.org/
http://www.railsmachine.com/ -- Need Mongrel support?



More information about the Mongrel-users mailing list