[Mongrel] Apache Proxy Error + Mongrel dying

Jacob Atzen jacob at jacobatzen.dk
Fri Aug 18 15:01:29 EDT 2006


On Fri, Aug 18, 2006 at 02:59:13PM +0200, Michele wrote:
> If I run Mongrel 0.3.13.4 in debug mode, I get this error before the  
> process dies: "Illegal instruction: 4 (core dumped)".
> 
> What could it be? Is there a way which instruction is causing the error?
> 
> Thanks,
> - Michele
> 
> On Aug 17, 2006, at 10:12 , Michele wrote:
> 
> > Hi,
> >
> > I've got to active project both running on the last Apache 2.2 and on
> > Mongrel 0.3.13.3.
> >
> > One is running perfectly, the other gets (always on the same pages,
> > but not after each request, it seems to be random) a ProxyError every
> > now and then which leads to the mongrel process being called to die
> > and subsequently slowing down the whole web site.
> > I have to restart the mongrel cluster and then it starts working well
> > again, but after a while, I get the same error again.
> >
> > I know of the Apache bug and put this in my httpd.conf:
> > #Fix for Apache bug 39499
> > SetEnv force-proxy-request-1.0 1
> > SetEnv proxy-nokeepalive 1
> >
> > It seemed to work at first, but now I'm getting the errors again.
> >
> > Would using 0.3.14 fix this? is it ready for production?

Hello list,

I'm seeing something like the same problem. Mongrels who suddenly stop
responding. I'm running an Apache mod_proxy with Mongrel backends setup.
And from time to time I'll get the following in the Apache error log
file:

[Fri Aug 18 20:28:53 2006] [error] [client xxx.xxx.xxx.xxx] proxy: error
reading status line from remote server 127.0.0.1
Fri Aug 18 20:28:53 2006] [error] [client xxx.xxx.xxx.xxx] proxy: Error
reading from remote server returned by ...

Additionally I'm experiencing Mongrels locking up hard. The only thing
to do to them is a kill -9. I'm also seeing Mongrels disappearing
without a trace in mongrel.log.
 
The problem seems to increase when the load is high, and I have a
feeling that increasing the number of mongrels somewhat increases the
time interval between lockups. Right now I'm running 20 mongrels and
haven't seen the problem for a while.

It should be noted that the application is not severely loaded. The
Rails production log seems to indicate something like 10 reqs/sec and
the requests processing time goes from 1 r/s and up to ~1000 r/s with
the majority running way above 10 r/s.

I haven't seen any core dumps even with debug turned on for Mongrel.

I'm on FreeBSD 6.1, Apache 2.2.3, Mongrel 0.3.13.4 (as I had another
issue and was advised to upgrade by Zed Shaw) and Rails 1.1.6 and
deploying with Mongrel_cluster and Capistrano.

Unfortunately I will not be able to provide further info for the next 2
weeks, but I do hope somebody will be able to figure out what is going
on with what little info is given.

-- 
Thanks,
- Jacob Atzen


More information about the Mongrel-users mailing list