[Mongrel] error starting mongrel: undefined method `resolve' for nil:Mongrel::URIClassifier (NoMethodError)

Nick Sieger nicksieger at gmail.com
Thu Aug 17 21:52:17 EDT 2006


On 8/17/06, kigsteronline at mac.com <kigsteronline at mac.com> wrote:
>
> $ mongrel_rails start
> ** Starting Mongrel listening at 0.0.0.0:3000
> /usr/local/ruby-1.8.4/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3/lib/
> mongrel.rb:666:in `register': undefined method `resolve' for
> nil:Mongrel::URIClassifier (NoMethodError)
>
> What am I missing?
>
> I installed it using "sudo gem install mongrel --include-dependencies"


Go back and install again and watch for errors.  The most likely culprit is
that the /usr/local/ruby-1.8.4/lib/ruby/gems/1.8/gems/mongrel-
0.3.13.3/ext/http11/http11.so didn't get moved to /usr/local/ruby-1.8.4
/lib/ruby/gems/1.8/gems
/mongrel-0.3.13.3/lib/http11.so during the installation process.

HTH,
/Nick
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/mongrel-users/attachments/20060817/61ce1e50/attachment.html 


More information about the Mongrel-users mailing list