[Mongrel] Start up error

Timothy Wright tgw529 at gmail.com
Mon Aug 14 20:48:43 EDT 2006


I am a complete newbie and am having trouble getting mongrel started up. I
cannot find any info about this error. If you can help at all, I would be
very grateful. Here is the error I get when I try and start my rails app
with mongrel. I have reomved and reinstalled Rails, Ruby, Daemons, and
Mongrel based on some other articles I found on this list. PLEASE HELP!


tim at rome:/www/app.tickspot.com$ sudo mongrel_rails start -e developement -p
80
** Starting Mongrel listening at 0.0.0.0:80 <http://0.0.0.0/>
** Starting Rails with developement environment ...
/usr/lib/ruby/gems/1.8/gems/rails-1.1.6/lib/initializer.rb:168:in `read': No
such file or directory -
/www/app.tickspot.com/config/../config/environments/developement.rb
(Errno::ENOENT)
        from /usr/lib/ruby/gems/1.8/gems/rails- 1.1.6/lib/initializer.rb:168:in
`load_environment'
        from /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/core_ext/kernel/reporting.rb:11:in
`silence_warnings'
        from /usr/lib/ruby/gems/1.8/gems/rails- 1.1.6/lib/initializer.rb:165:in
`load_environment'
        from /usr/lib/ruby/gems/1.8/gems/rails-1.1.6/lib/initializer.rb:82:in
`process'
        from /usr/lib/ruby/gems/1.8/gems/rails-1.1.6/lib/initializer.rb:42:in
`run'
        from /www/app.tickspot.com/config/environment.rb:13
        from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:21:in
`require'
        from /usr/lib/ruby/gems/1.8/gems/mongrel-0.3.13.2/lib/mongrel/rails.rb:156:in`rails'
        from /usr/lib/ruby/gems/1.8/gems/mongrel-
0.3.13.2/bin/mongrel_rails:104:in `cloaker_'
        from /usr/lib/ruby/gems/1.8/gems/mongrel-
0.3.13.2/lib/mongrel.rb:845:in `listener'
        from /usr/lib/ruby/gems/1.8/gems/mongrel-0.3.13.2/bin/mongrel_rails:91:in
`cloaker_'
        from /usr/lib/ruby/gems/1.8/gems/mongrel-
0.3.13.2/lib/mongrel.rb:763:in `initialize'
        from /usr/lib/ruby/gems/1.8/gems/mongrel-0.3.13.2/bin/mongrel_rails:78:in`run'
        from /usr/lib/ruby/gems/1.8/gems/mongrel-
0.3.13.2/lib/mongrel/command.rb:211:in `run'
        from /usr/lib/ruby/gems/1.8/gems/mongrel-
0.3.13.2/bin/mongrel_rails:227
        from /usr/bin/mongrel_rails:18



-- 
Grace and Peace,
Timothy G. Wright
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/mongrel-users/attachments/20060814/1d8d029a/attachment.html 


More information about the Mongrel-users mailing list