[Mongrel] mongrel still fails to write pid file when starting with config file

Chris Hall christopher.k.hall at gmail.com
Fri Aug 11 07:21:06 EDT 2006


upgraded to 0.3.13.4 this morning in order to correct the above titled
problem but mongrel is still not writing the pid file when starting
with a config file

verified i am running 03.13.4 with --version

if i run this command:

mongrel_rails start -p 3000 -e production -d --user mongrel --group webdev

mongrel DOES create the pid file

if i run the same, and include -G config/mongrel.conf, the following
is generated in the config file:

---
:user: mongrel
:host: 0.0.0.0
:mime_map:
:prefix:
:port: "3000"
:daemon: true
:cwd: /srv/www/railsapps/myapp
:includes:
- mongrel
:environment: production
:group: webdev
:log_file: log/mongrel.log
:timeout: 0
:config_script:
:pid_file: log/mongrel.pid
:num_processors: 1024
:debug: false
:docroot: public

i then run mongrel_rails start -C config/mongrel.conf and mongrel
start, but the pid file is still not written.  the log directory perms
are 775 and owned by group webdev.  in addition the mogrel.log file is
being written.

verfied this on 2 separate systems.

i went and looked this up in the buglist and found
http://rubyforge.org/tracker/?group_id=1306&atid=5145&func=detail&aid=5119
.  i saw someone had submitted a diff for 03.13.3, but this fix is not
in 0.3.13.4.  i patched and now the pid file is written.

Chris


More information about the Mongrel-users mailing list