[Mongrel] Software caused connection abort

Philip Lipu Tsai tsailipu at gmail.com
Thu Aug 10 11:58:33 EDT 2006


 Hi Zed or anyone that is also looking at Mongrel,

 Just want to report something that, although doesn't crash mongrel, is
rather annoying.

 I am running the latest Mongrel 0.3.13.3 - ruby version on cygwin
(yeah, poor me).  When I start mongrel_rails with
ActiveRecord::Base.allow_concurrency = true in environment.rb, I see a
lot of
  "Error sending file /cygdrive/c/[snipped]/[default java scripts].js
: Software caused connection abort"

 While these don't cause any harm, they are concerning...
 Also, I see the following error more often as well:

Lost connection to MySQL server during query
 [ the exception traces vary but do involve routing; here is an example:]
/usr/lib/ruby/gems/1.8/gems/activerecord-1.14.3/lib/active_record/vendor/mysql.rb:1112:in
`write'
/usr/lib/ruby/gems/1.8/gems/activerecord-1.14.3/lib/active_record/vendor/mysql.rb:1162:in
`finalizer'
/usr/lib/ruby/gems/1.8/gems/actionpack-1.12.3/lib/action_controller/code_generation.rb:54:in
`<<'
/usr/lib/ruby/gems/1.8/gems/actionpack-1.12.3/lib/action_controller/routing.rb:548:in
`generation_code_for'
/usr/lib/ruby/gems/1.8/gems/actionpack-1.12.3/lib/action_controller/code_generation.rb:46:in
`method_missing'
/usr/lib/ruby/gems/1.8/gems/actionpack-1.12.3/lib/action_controller/code_generation.rb:19:in
`indent'
/usr/lib/ruby/gems/1.8/gems/actionpack-1.12.3/lib/action_controller/code_generation.rb:46:in
`method_missing'
/usr/lib/ruby/gems/1.8/gems/actionpack-1.12.3/lib/action_controller/routing.rb:545:in
`generation_code_for'
/usr/lib/ruby/gems/1.8/gems/actionpack-1.12.3/lib/action_controller/routing.rb:488:in
`write_generation'
/usr/lib/ruby/gems/1.8/gems/actionpack-1.12.3/lib/action_controller/routing.rb:482:in
`write_generation'
/usr/lib/ruby/gems/1.8/gems/actionpack-1.12.3/lib/action_controller/routing.rb:629:in
`draw'
#{RAILS_ROOT}/config/routes.rb:1
/usr/bin/mongrel_rails:18

 When I see such page, refreshing once or twice typically works.

 With  ActiveRecord::Base.allow_concurrency set to false (i.e. the
default), everything chugs along pretty well.   Don't know whether
this problem is particular to cygwin environment or is generic when
one turns on ActiveRecord::Base.allow_concurrency (or this is just my
system...).

 Philip


More information about the Mongrel-users mailing list