[Mongrel] Win32 Gem Dependencies

Josh Ferguson josh at besquared.net
Wed Apr 19 13:34:53 EDT 2006

It's there but the require fails in irb for some reason. I guess this is 
a problem I'll have to figure out with my setup.. :)

Josh Ferguson

Zed Shaw wrote:
> Uh, I'm not sure how that's possible unless the http11.so extension isn't
> being installed or compiled.  Check in your gem directory and see if it's
> there.  The http11 extension is what provides the resolve method.
> I vaguely remember that a similar problem happens on Solaris due to a ruby
> extconf.rb problem and how the install command works.  Seems that people
> just fix it by moving the ext/http11/http11.so file over to lib inside the
> gem's directory.
> Zed
> On 4/19/06 1:18 AM, "Josh Ferguson" <josh at besquared.net> wrote:
>> Since we're on the topic of Win32, I'm having a hell of a time getting
>> mongrel on to run with or without the service. I use Windows XP Pro and
>> Cygwin to do everything on my machine. The problem is that mongrel
>> starts successfully but then when the first request comes in I get the
>> following stack trace:
>> $ mongrel_rails start
>> ** Starting Mongrel in development mode at
>> ** Starting Rails in environment development ...
>> /usr/lib/ruby/gems/1.8/gems/mongrel-
>> `register': undefined method `resolve' for ni
> _______________________________________________
> Mongrel-users mailing list
> Mongrel-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/mongrel-users

More information about the Mongrel-users mailing list