[Mongrel] Win32 Gem Dependencies

Josh Ferguson josh at besquared.net
Wed Apr 19 01:18:45 EDT 2006


Since we're on the topic of Win32, I'm having a hell of a time getting 
mongrel on to run with or without the service. I use Windows XP Pro and 
Cygwin to do everything on my machine. The problem is that mongrel 
starts successfully but then when the first request comes in I get the 
following stack trace:

$ mongrel_rails start
** Starting Mongrel in development mode at 0.0.0.0:3000
** Starting Rails in environment development ...
/usr/lib/ruby/gems/1.8/gems/mongrel-0.3.12.4-mswin32/lib/mongrel.rb:539:in 
`register': undefined method `resolve' for ni
l:Mongrel::URIClassifier (NoMethodError)
        from 
/usr/lib/ruby/gems/1.8/gems/mongrel-0.3.12.4-mswin32/lib/mongrel.rb:675:in 
`uri'
        from 
/usr/lib/ruby/gems/1.8/gems/mongrel-0.3.12.4-mswin32/bin/mongrel_rails:82:in 
`cloaker_'
        from 
/usr/lib/ruby/gems/1.8/gems/mongrel-0.3.12.4-mswin32/lib/mongrel.rb:658:in 
`listener'
        from 
/usr/lib/ruby/gems/1.8/gems/mongrel-0.3.12.4-mswin32/bin/mongrel_rails:69:in 
`cloaker_'
        from 
/usr/lib/ruby/gems/1.8/gems/mongrel-0.3.12.4-mswin32/lib/mongrel.rb:616:in 
`initialize'
        from 
/usr/lib/ruby/gems/1.8/gems/mongrel-0.3.12.4-mswin32/bin/mongrel_rails:61:in 
`run'
        from 
/usr/lib/ruby/gems/1.8/gems/mongrel-0.3.12.4-mswin32/lib/mongrel/command.rb:163:in 
`run'
        from 
/usr/lib/ruby/gems/1.8/gems/mongrel-0.3.12.4-mswin32/bin/mongrel_rails:194
        from /usr/bin/mongrel_rails:18

I'm not intimate with the code but I looked through it and I couldn't 
find 'resolve' as a member of URIClassifier or any mixins or run-time 
extendings that added it. Any help would be appreciated as I'd really 
love to get this thing running..:)

Hating windows
Josh Ferguson

Zed Shaw wrote:
> Ok, on the bug list.  I'm doing a 0.3.12.5 release tomorrow or so and I'll
> get this fixed up.  I have to do lots of testing and fixing up mongrel on
> win32 anyway.
>
> Zed
>
>
> On 4/18/06 11:14 PM, "Josh Ferguson" <josh at besquared.net> wrote:
>
>   
>> Yeah I just noticed that the latest mongrel gem for win32 doesn't have
>> the proper dependency for 'daemons'. This of course causes the require
>> to fail. Any chance at getting this fixed for future gems? :)
>>
>> Thanks
>> Josh Ferguson
>> _______________________________________________
>> Mongrel-users mailing list
>> Mongrel-users at rubyforge.org
>> http://rubyforge.org/mailman/listinfo/mongrel-users
>>     
>
> _______________________________________________
> Mongrel-users mailing list
> Mongrel-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/mongrel-users
>
>   



More information about the Mongrel-users mailing list