Ruby 2.0 Bad file descriptor (Errno::EBADF)

Eric Wong normalperson at
Fri Aug 23 06:47:37 UTC 2013

port <port.himmerland at> wrote:
> Eric Wong <normalperson <at>> writes:
> > Did you upgrade to Ruby 2.0.0 before upgrading to unicorn 4.1+?
> we've been running a unicorn 4.6.3 setup on ruby 1.9.3 for quite a while
> with no similar issues. i'll keep digging through our lifecycle config
> to see if i can get closer to the cause.

OK, this is really strange; especially since you're only hitting this
on your legacy app and not a new one.

I certainly haven't hit this with Ruby 2.0.0 anywhere (neither unicorn
nor Rainbows!).  I'm fairly certain enough folks are using Ruby 2.0.0 by
now that we would have more reports if something were amiss.

Let us know what you find, thanks!

More information about the mongrel-unicorn mailing list