FreeBSD jail and unicorn

Eric Wong normalperson at yhbt.net
Tue Feb 7 00:21:30 EST 2012


Eric Wong <normalperson at yhbt.net> wrote:
> ruby-core pointed me to the following issue:
>   https://bugs.ruby-lang.org/issues/5757
> 
> So there may already be a fix in Ruby SVN, can you test?
> http://svn.ruby-lang.org/repos/ruby/branches/ruby_1_9_3 r34425

Btw, did anybody get a chance to try this?

While working on an unrelated project, I setup FreeBSD 8.2 and 9.0
KVM images over the weekend.  Since I had the KVM images handy, I also
tried to reproduce this issue under 1.9.3-p0 (without a jail) but was
unable to reproduce the issue under either 8.2 nor 9.0.

I tried building a jail, but didn't have enough space for a full one.
If I get the chance, I'll see how building a partial jail goes, but I'm
not optimistic about being able to reproduce this issue under KVM
since it seems to be a race condition/timing issue.

I even had both CPU cores enabled under KVM and even installed the
virtio drivers for better performance.

I assume you guys are using SMP in the jail?


More information about the mongrel-unicorn mailing list