Kernel.srand after_fork

Eric Wong normalperson at
Fri Jan 28 12:51:11 EST 2011

ghazel at wrote:
> So, calling Kernel.srand in after_fork will fix the 1.8 bug and the
> 1.9.1 bug and work fine on 1.9.2?

Yes.  The 1.9.1 bug is fixed in p429 AFAIK, but I seem to recall p429
being completely broken with gems.  Just use 1.9.2 if you're on 1.9

Eric Wong

More information about the mongrel-unicorn mailing list