rack 1.2 version causing misleading error msg

Don Park don.park at gmail.com
Mon Feb 28 11:23:14 EST 2011


The problem: (note this is the only ruby on the system and rvm/bundler
is not being used)

$ gem list rails

*** LOCAL GEMS ***
rails (2.3.10, 2.3.8, 2.3.5)

$ unicorn_rails
I, [2010-11-23T15:03:12.134222 #1297]  INFO -- : listening on
addr=0.0.0.0:8080 fd=3
I, [2010-11-23T15:03:12.134499 #1297]  INFO -- : worker=0 spawning...
I, [2010-11-23T15:03:12.136120 #1300]  INFO -- : worker=0 spawned
pid=1300
I, [2010-11-23T15:03:12.136507 #1300]  INFO -- : Refreshing Gem list
I, [2010-11-23T15:03:12.136374 #1297]  INFO -- : master process ready
Missing the Rails 2.3.10 gem. Please `gem install -v=2.3.10 rails`,
update your RAILS_GEM_VERSION setting in config/environment.rb for the
Rails version you do have installed, or comment out RAILS_GEM_VERSION to
use the latest version installed.

After much experimentation, the problem is the existence of rack 1.2.1

$ sudo gem uninstall rack

Select gem to uninstall:
 1. rack-1.1.0
 2. rack-1.2.1
 3. All versions
> 2

donp at donpdonp:~/everyonedelivers$ unicorn_rails
I, [2010-11-23T15:26:40.729596 #2202]  INFO -- : listening on
addr=0.0.0.0:8080 fd=3
I, [2010-11-23T15:26:40.729869 #2202]  INFO -- : worker=0 spawning...
I, [2010-11-23T15:26:40.731081 #2204]  INFO -- : worker=0 spawned
pid=2204
I, [2010-11-23T15:26:40.731263 #2204]  INFO -- : Refreshing Gem list
I, [2010-11-23T15:26:40.734943 #2202]  INFO -- : master process ready

worker=0 ready





More information about the mongrel-unicorn mailing list