unicorn_rails in a loop of not starting...

Eric Wong normalperson at yhbt.net
Wed Jun 9 14:43:56 EDT 2010


Philip Ingram <philip at ingraminternet.com> wrote:
> Hi,
> 
> Sorry for the subject, just  not sure what is going on and how to describe it.
> 
> Problem:
> -------------
> When running unicorn_rails in my RAILS_ROOT directory (the same one where the script/server command runs fine) i get terminal printout  saying:
> ==================
> unicorn_rails worker[0] --path /Users/me/current_project/project -l0.0.0.0:8080 must be run inside RAILS_ROOT: #<LoadError: no such file to load -- config/boot>

<snip>

Hi Philip,

> I am running Rails 2.3.8, Ruby 1.9.2-head and have both rack (1.1.0,
> 1.0.1) installed, or else rails won't boot up for some silly reason.
> (I.e., if i uninstall 1.1.0, rails cries that it needs 1.0.1).  I am
> also running unicorn (0.990.0) (fresh install) .  All of this through
> rvm 0.1.37.

Try the prerelease on Rubygems.org: unicorn 0.990.0.5.gbfb1 `gem install
--pre unicorn`.  Ruby 1.9.2 no longer has '.' in its default
$LOAD_PATH, so instead of "require 'config/boot'" we have to do
"require ::File.expand_path('config/boot')"

> Am i missing some installation steps that aren't described in the
> README/github page?  running unicorn_rails in my root directory should
> just work right?

I'm not sure which github page you're referring to without the full URL,
but the official docs are online at http://unicorn.bogomips.org/ (and
always distributed with the source tree).

Anyways, the prerelease should help and not introduce any regressions.
I plan on having 0.991.0 out in the next day or two.

-- 
Eric Wong


More information about the mongrel-unicorn mailing list