listen backlog

ghazel at ghazel at
Fri Dec 3 17:49:22 EST 2010

On Fri, Dec 3, 2010 at 1:49 PM, Eric Wong <normalperson at> wrote:
> ghazel at wrote:
>> Using "modprobe inet_diag" made the script spit out a new error:
>>             address     active     queued
>> linux-tcp-listener-stats.rb:42:in `tcp_listener_stats': NLMSG_ERROR
>> (RuntimeError)
>>         from linux-tcp-listener-stats.rb:42
> I don't think I've ever seen NLMSG_ERROR before.  Are you running
> this as the same user that originally bound the listener (the user
> of the Unicorn master process)?

Yes. I also tried as root, same error.

>> $ sudo modprobe -l inet_diag
>> /lib/modules/
>> I dug in to raindrops a little bit, and it seems the error associated
>> with the NLMSG_ERROR is -2,
>> "No such file or directory".
> Are you bound to and not  Use
> if you're bound to that (I had another user on the
> raindrops mailing list with that problem).

My unicorn.rb says But just to test I tried fetching stats
for but got the same error.


More information about the mongrel-unicorn mailing list